Pomiń i przejdź do głównej zawartości
Zadzwoń do nas
Numery telefonów i godziny
Centrum pomocy

Sprawdź nasze zasoby pomocy online

Pomoc

system WordPress Pomoc

Dołożyliśmy wszelkich starań, aby przetłumaczyć tę stronę. Dostępna jest również strona w języku angielskim.

Uruchom aktualizacje w systemie WordPress za pomocą WP-CLI

WP-CLI to narzędzie wiersza poleceń, które pomaga wykonywać różne czynności w witrynie WordPress. Jeśli nie masz nic przeciwko używaniu poleceń SSH, zauważysz, że WP-CLI ma uproszczone polecenia utworzone dla witryn WordPress. Oto jak zaktualizować WordPress, wtyczki i motywy za pomocą poleceń dostępnych w WP-CLI.

Ostrzeżenie: przed uruchomieniem aktualizacji należy zawsze wykonać kopię zapasową witryny .
Wymagania: do wykonania tych czynności potrzebne będą następujące elementy:
Uwaga: Jeśli masz serwer VPS lub DED, musisz zainstalować WP-CLI , zanim zaczniesz go używać. WP-CLI nie jest dostępny w naszych planach hostingu Windows.
  1. Połącz się ze swoim kontem hostingowym za pomocą SSH .
  2. Użyj polecenia bash ls , aby wyświetlić listę plików i folderów, a także cd i ../ , aby poruszać się po katalogach, aż znajdziesz się w katalogu z plikami WordPressa.
  3. Wprowadź następujące polecenia, aby uruchomić aktualizacje:
    • Aby zaktualizować rdzeń WordPressa: aktualizacja rdzenia
      wp
      Uwaga: Plany zarządzanego systemu WordPress działają na najnowszej wersji systemu WordPress. Za każdym razem, gdy pojawi się aktualizacja, zainstalujemy ją automatycznie.
    • Aby zaktualizować jedną wtyczkę:
      wp aktualizacja wtyczki nazwa-wtyczki
      W powyższym kodzie zastąp nazwę wtyczki rzeczywistą nazwą wtyczki, którą chcesz zaktualizować.
    • Aby zaktualizować wszystkie wtyczki:
      wp plugin update --all
    • Aby zaktualizować jeden motyw:
      wp theme update nazwa-motywu
      W powyższym kodzie zastąp nazwę motywu rzeczywistą nazwą motywu, który chcesz zaktualizować.
    • Aby zaktualizować wszystkie motywy:
      wp theme update --all
  4. Po wyświetleniu komunikatu o powodzeniu odwiedź witrynę w przeglądarce i sprawdź, czy nie zawiera błędów. W przypadku znalezienia błędów sprawdź dokumentację wtyczki lub motywu.

Ze względów bezpieczeństwa zalecamy aktualizowanie systemu WordPress, wtyczek i motywów.

Więcej informacji