Pomiń i przejdź do głównej zawartości
Zadzwoń do nas
Numery telefonów i godziny
Centrum pomocy

Sprawdź nasze zasoby pomocy online

Pomoc

Zarządzany system WordPress Pomoc

Dołożyliśmy wszelkich starań, aby przetłumaczyć tę stronę. Dostępna jest również strona w języku angielskim.

Wycofanie starych wersji PHP

Ostrzeżenie: W lipcu 2022 r. Będziemy wycofywać wszystkie wycofane z eksploatacji (EOL) wersje języka PHP na naszej platformie hostingowej Managed WordPress.

PHP to język programowania, na którym oparty jest kod WordPressa. Ten język działa na serwerze i jego aktualność jest ważna dla bezpieczeństwa i funkcjonalności witryny WordPress.

Wybierz pytanie, aby zobaczyć odpowiedź:

Dlaczego tak się dzieje?

Wersje wycofane z eksploatacji (EOL) nie są już obsługiwane w zakresie aktualizacji zabezpieczeń, co może spowodować zagrożenie dla witryny WordPress. Aktualizacja do bieżącej wersji PHP może również poprawić wydajność i stabilność większości witryn.

Aby się do tego przygotować, przygotowujemy się do wycofania następujących wersji PHP:

  • 5.6
  • 7,0, 7,1, 7,2, 7,3

Skąd mam wiedzieć, której wersji PHP używam?

Swoją wersję PHP można zobaczyć w kilku lokalizacjach:

  • Panel hostingu Managed WordPress: W sekcji Ustawienia wybierz opcję Witryna produkcyjna , a następnie Wersja PHP . Możesz również zaktualizować swoją wersję PHP tutaj.
  • Pulpit nawigacyjny WordPress: Na stronie głównej zostanie wyświetlony komunikat administratora Wymagana aktualizacja PHP . Kliknij łącze, aby zaktualizować wersję języka PHP.
  • Skrypt informacyjny PHP: Możesz utworzyć plik informacyjny PHP i umieścić go w swoim katalogu public_html. Spowoduje to wyświetlenie informacji o wersji PHP, gdy plik zostanie załadowany w przeglądarce.

Co mi pan poleca?

Jeśli Twoja witryna działa w wersji języka PHP EOL, zalecamy podjęcie działań proaktywnych i aktualizowanie witryny.

Najpierw zaktualizuj wtyczki i aktywny motyw . Jest to najbardziej prawdopodobna przyczyna problemów podczas aktualizacji wersji PHP dla Twojej witryny WordPress. Skorzystaj z okazji, aby przejrzeć dokumentację programisty dotyczącą wtyczek i motywu, aby sprawdzić, czy występują problemy, o których należy pamiętać podczas aktualizacji wersji PHP.

Nasze plany Deluxe, Ultimate i Ecommerce Managed WordPress obejmują witrynę testową za jednym kliknięciem, w której możesz przetestować swoją witrynę na najnowszej wersji PHP. Jest to doskonałe miejsce do rozwiązywania problemów i pokonywania wszelkich problemów, które możesz napotkać bez wpływu na działającą witrynę. Po zakończeniu aktualizacji i naprawieniu problemów w witrynie testowej możesz wprowadzić zmiany do działającej witryny.

Uwaga: Jeśli Twoja witryna korzysta z planu podstawowego Managed WordPress, musisz przejść na plan Deluxe, Ultimate lub Ecommerce, aby uzyskać dostęp do środowiska przejściowego. ( Oto jak zaktualizować )

W zależności od wersji języka PHP EOL, na której działa Twoja witryna, może nie być konieczne wiele zmian, aby witryna działała prawidłowo. Im starsza wersja, tym więcej pracy może wymagać przygotowanie witryny do zmiany.

Jeśli Twoja witryna korzysta z języka PHP w wersji 5.6, zapoznaj się z funkcjami, które są przestarzałe w języku PHP 7.0.x na stronie PHP.net. Może być konieczne zaangażowanie programisty lub administratora WordPressa, aby zapewnić prawidłowe działanie witryny po zmianie wersji PHP.

Jeśli Twoja witryna korzysta z PHP 7.0–7.3, informacje o migracji do nowszej wersji znajdziesz w dodatkach w witrynie PHP.net.

Jeśli nie masz programisty lub administratora WordPressa, który mógłby pomóc Ci w tworzeniu witryny, skorzystaj z naszej płatnej usługi pomocy technicznej WordPress Premium .

Jak zmienić wersję PHP?

W sekcji Ustawienia panelu hostingu Managed WordPress możesz zmienić wersję PHP .

Co się stanie, jeśli nic nie zrobię?

Jeśli Twoja witryna korzysta obecnie z wersji języka PHP EOL i nie podejmiesz żadnych działań, niektóre aspekty witryny mogą nie działać, jeśli zależą one od wycofanego kodu w starszych wersjach. Jeśli nie masz pewności, skontaktuj się z programistą lub administratorem WordPressa.

Ponieważ wersje języka PHP EOL są wycofywane, każdy, kto nadal używa wersji EOL, zauważy, że jego witryna została zmieniona na nowszą, stabilną wersję PHP.